Gennemsnit - min og max

Formler til gennemsnit, mindste, største og andre smarte formål

 

Formler til gennemsnit, mindste, største og median med eller uden kriterier kan løse mange små udfordringer i hverdagen, selvom det nok ikke er så tit du støder på dem.
Disse mere spektakulære formler kommer nok ind under kategorien cowboytricks og kan ikke huskes i hovedet (jeg kan altså ikke huske dem fra gang til gang). Brug siden her som opslagsværk når du har behovet.

 

↓Klik for at få vist formel og forklaring↓



 

↑Til toppen

Gennemsnit af de 5 laveste tal i et område

Denne formel laver et simpelt gennemsnit at de 5 laveste tal i området A1:A10
Du kan selv ændre array'et {1;2;3;4;5} hvis du ønsker gennemsnit af andet en de 5 laveste.
Hvis du ønsker gennemsnit af de fx 10 laveste, skal du ændre array'et til {1;2;3;4;5;6;7;8;9;10}

=MIDDEL(MINDSTE(A1:A10;{1;2;3;4;5}))

 

↑Til toppen

Gennemsnit af de 5 laveste tal som er større end 0

Denne formel laver et simpelt gennemsnit at de 5 laveste tal i området A1:A10 som er større end 0
Du kan selv ændre array'et {1;2;3;4;5} hvis du ønsker gennemsnit af andet en de 5 højeste.
Hvis du ønsker gennemsnit af de fx 10 højeste, skal du ændre array'et til {1;2;3;4;5;6;7;8;9;10}

=MIDDEL(MINDSTE(A1:A10;{1;2;3;4;5}+TÆL.HVIS(A1:A10;0)))

 

↑Til toppen

Median.hvis !!! - Median med kriterier

Med denne formel kan du lave en median med kriterier.
Formlen er en matrixformel, som altid skal afsluttes ved at holde CTRL og SHIFT nede samtidig med at du trykker én gang på ENTER
Du kan se om du har gjort det rigtigt ved at der kommer tuborgklammer { } omkring formlen.
Hvis du ikke afslutter denne formel som beskrevet i ovenstående, vil den ikke virke korrekt.

=MEDIAN(HVIS(A1:A10=1;B1:B10))

 

↑Til toppen

Min.Hvis !!! - Min med kriterier

Med denne formel kan du finde den mindste værdi i et område med kriterier.
Formlen er en matrixformel, som altid skal afsluttes ved at holde CTRL og SHIFT nede samtidig med at du trykker én gang på ENTER
Du kan se om du har gjort det rigtigt ved at der kommer tuborgklammer { } omkring formlen.
Hvis du ikke afslutter denne formel som beskrevet i ovenstående, vil den ikke virke korrekt.

=MIN(HVIS((A:A="mandag");B:B;""))

 

↑Til toppen

Maks.Hvis !!! - Maks med kriterier

Med denne formel kan du finde den største værdi i et område med kriterier.
Formlen er en matrixformel, som altid skal afsluttes ved at holde CTRL og SHIFT nede samtidig med at du trykker én gang på ENTER
Du kan se om du har gjort det rigtigt ved at der kommer tuborgklammer { } omkring formlen.
Hvis du ikke afslutter denne formel som beskrevet i ovenstående, vil den ikke virke korrekt.

=MAKS(HVIS((A:A="mandag");B:B;""))

 

Opdateret 10-02-2017 14:59:41