Tæl og antal

Tæl i alle afskygninger

 

At tælle er en af de ting som Excel er rigtig god til. Den mest simple måde at vise det på, er at markere en masse celler med indhold og derefter aflæse antal og sum i Excel's nederste højre hjørne.
Excel kan via formler gøre dette mere elegant og hvis man er opfindsom nok, kan man lave formler som disse som tæller på utallige måder.

 

↓Klik for at få vist formel og forklaring↓


Tæl unikke værdier i et område

Tæl antallet af synlige celler i et område - med et kriterie

Tæl antallet af viste rækker i et område med AutoFilter (skjulte celler medregnes)

Tæl antal ord i en celle

Tæl alle forekomster af et ord eller et bogstav i et område

Et meget simpelt pindediagram i en celle.


 

 

↑Til toppen

Tæl unikke værdier i et område

Denne formel tæller antallet af unikke værdier i området A1:A10
Formlen udelader tomme celler.

=SUMPRODUKT((A1:A10<>"")/TÆL.HVIS(A1:A10;A1:A10&""))

 

↑Til toppen

Tæl antallet af synlige celler i et område - med et kriterie

Formlen tæller antallet af synlige celler i et område, som indeholder en bestemt tekst eller værdi.
Kan også bruges til at tælle synlige rækker i et område filtreret med autofiler.
I dette eksempel, tæller formlen alle forekomster af 'Ja' i området A1:A10, i celler hvor rækken ikke er skjult.

=SUMPRODUKT(SUBTOTAL(103;INDIREKTE("A"&RÆKKE($A1:$A10)))*(A1:A10="Ja"))

Formlen skal ændres til nedenstående hvis du bruger Excel XP 2002 eller ældre.

=SUMPRODUKT((A1:A10="Ja")*SUBTOTAL(103;FORSKYDNING(A1;RÆKKE(A1:A10)-RÆKKE(A1);0)))

 

↑Til toppen

Tæl antallet af viste rækker i et område med AutoFilter (skjulte celler medregnes)

Formlen tæller antallet af synlige celler i et område som er filtreret med autofiler.
Bemærk at skjulte rækker tælles med.
I dette eksempel, tæller formlen alle forekomster af 'Ja' i området A1:A10.

=SUMPRODUKT(SUBTOTAL(3;FORSKYDNING(A1:A10;RÆKKE(A1:A10)-MIN(RÆKKE(A1:A10));;1))*(A1:A10="Ja"))

 

↑Til toppen

Tæl antal ord i en celle

Formlen tæller antallet af ord i cellen A1

=HVIS(A1<>"";1;0)+LÆNGDE(FJERN.OVERFLØDIGE.BLANKE(A1))-LÆNGDE(UDSKIFT(A1;" ";""))

 

↑Til toppen

Tæl antal forekomster af et ord eller et bogstav i et område

Formlen tæller antallet af matchende ord eller bogstaver i området A1:A10
I dette eksempel søges efter bogstevet 'hej'. Formlen tæller antallet af forekomster, også hvis der skulle være flere hits i samme celle.
VIGTIGT: Formlen er en matrixformel, som altid skal afsluttes ved at holde CTRL og SHIFT nede samtidig med at du trykker én gang på ENTER. Du kan se om du har gjort det rigtigt ved at der kommer tuborgklammer { } omkring formlen.
Hvis du ikke afslutter denne formel som beskrevet i ovenstående, vil den ikke virke korrekt

=SUM((LÆNGDE(A1:A10)-LÆNGDE(UDSKIFT(A1:A10;"hej";"")))/LÆNGDE("hej"))

Hvis du kun har behov for at finde antallet af et enkelt bogstav, kan du 'nøjes' med denne formel
I eksemplet tælles alle forekomster af bogstavet e.

=SUMPRODUKT(LÆNGDE(A1:A10)-LÆNGDE(UDSKIFT(A1:A10;"e";"")))

 

↑Til toppen

Et meget simpelt pindediagram i en celle

Laver et lille simpelt pindediagram, som nogle gange kan være tilstrækkeligt :-)

=GENTAG("I";A1)

 

 

Opdateret 10-02-2017 14:59:49