Rækker og kolonner

Rækker og kolonner

Ofte må man ty til VBA for at finde den nederste række eller det sidste tal i kolonne, men formler kan altså gøre det på en langt mere elegant måde. Disse formler gør det nemt at få disse informationer op i en celle.
Der er egentlig ikke så meget magi i det.

 

↓Klik for at få vist formel og forklaring↓



 

↑Til toppen

Find rækkenummeret, på cellen hvor indholdet matcher

Formlen returnerer rækkenummeret på den celle hvor indholdet svarer til det du ønsker.
I dette eksempel søges der i området A1:A10. Hvis formlen finder en celle som er lig med 'ja', returnerer den rækkenummeret for cellen.

=SAMMENLIGN("ja";A1:A10;0)

 

↑Til toppen

Find rækkenummeret på den sidste (nederste) celle i en kolonne

Formlen returnerer rækkenummeret på den sidste 'ikke tomme' celle i en kolonne

=SUMPRODUKT(MAKS((RÆKKE(A:A))*(A:A<>"")))

 

↑Til toppen

Find værdien eller teksten fra den sidste (nederste) celle i en kolonne

Henter værdien eller teksten fra den sidste celle i kolonnen.
Formlen skelner ikke mellem tal eller tekst, men returnerer blot indholdet fra den sidste celle i kolonnen.

=SLÅ.OP(2;1/(1-ER.TOM(A:A));A:A)

 

↑Til toppen

Find det sidste (nederste) tal i en kolonne

Henter værdien fra den sidste celle i kolonnen som indeholder et tal.
Formlen ignorerer celler med tekst og finder kun den sidste celle som indeholder et tal.

=SLÅ.OP(9^99;A:A)

 

Opdateret 10-02-2017 15:00:01