Tast klokkeslæt uden kolon

Nem indtastning af klokkeslæt - tast tid uden kolon og regn på tværs af midnat

 

Det kan være irriterende hele tiden at skulle huske at taste ":" kolon hele tiden, når man taster tid i Excel.
Ofte er det vagtplaner eller timeskemaer som irriterer mest, da det typisk er gentagelse efter gentagelse som gør at Excel's tidsformat med kolon er så dræbende.
Med denne metode slipper du for det.
Som en ekstra bonus, får du også tricket til at regne hen over midnat. Det er særdeles praktisk hvis du arbejder med nattevagter eller på anden måde har brug for at beregne timer på tværs af midnat.

Slip for kolon i Excel's tidsformat

I stedet for 08:45 skal du blot taste 845
I stedet for 20:59 skal du blot taste 2059

Eksempler:
Tast 015 for kl 00:15
Tast 100 for kl 01:00
Tast 2045 for kl 20:45
Det er meget intuitivt når du først får det ind under huden.

Metoden er formelbaseret og indeholder ingen kode eller makroer overhovedet.
Orker du ikke at gøre arbejdet selv, kan du hente et regneark hvor det hele er lavet på forhånd.
Det er vigtigt at du læser manualen herunder alligevel.

Sådan gør du:

1. Formater cellerne A1 og B1 med formatet

2. Formater cellen C1 med formatet

 3. Sæt nedenstående formel ind i C1

=HVIS(ELLER(C5="";D5="");0;HVIS(VÆRDI(C5)>=VÆRDI(D5);(TID(AFKORT(D5/100);REST(D5;100);0))+1-(TID(AFKORT(C5/100);REST(C5;100);0));(TID(AFKORT(D5/100);REST(D5;100);0))-(TID(AFKORT(C5/100);REST(C5;100);0))))

 

Nu er du klar til at registrere tid

Når du taster 800 i starttid, og 1600 i sluttid, ser resultatet ud som herunder.
Det er vigtigt at du ikke taster kolon.

Vil du regne på tværs at midnat, taster du blot dine klokkeslæt ind. Formlen regner rigtigt hver gang.


 

Opdateret 10-02-2017 15:00:08