Excel Standard Formler

Excel-regneark.dk - detaljeret hjælp til Excel formler på Dansk!

 

Klik på den Excelformel som du vil have hjælp til, så vil du finde detaljeret Dansk hjælp til den valgte formel.
Du får en god og enkel forklaring på alle formlerne, typiske eksempler på typisk brug, samt forslag til mere avanceret brug.

Formlerne er i de fleste tilfælde lavet så de tager udgangspunkt i den værdi du har i cellen A1, så lad være med at sætte selve formlen ind i A1, men læs vejledningen som vil beskrive hvor formlen henter værdier fra.
 

 

↓Klik på teksten for at få vist formel og forklaring↓



 

↑Til toppen

ANTAL.ARBEJDSDAGE bruges til at finde antallet af arbejdsdage mellem 2 datoer.

ANTAL.ARBEJDSDAGE er genial til at finde antallet af hverdage, minus helligdage, ferie og andet.

Formlen ser således ud: =ANTAL.ARBEJDSDAGE(A1;B1;C1:C50)

Ovenstående formel har en Startdato i A1, en Slutdato i B1 og et område i C1:C50 hvor du kan skrive helligdage, ferie, mærkedage evt.
Området hellig/feriedage vil ikke blive medregnet i antallet af dage mellem de to datoer.

Du kender sikkert en pap-kalender. Forneden er der som regel en opgørelse over arbejdsdage. Det er her denne formel kommer til sin ret.


↑Til toppen

ARBEJDSDAG kan b.la. bruges til at regne antal af arbejdsdage frem eller tilbage, med udgangspunkt i en dato.

ARBEJDSDAG er rigtig god til at beregne estimeret leveringstid/ventetid, hvor der tages højde for helligdage, ferie og andet.

Formlen ser således ud: =ARBEJDSDAG(A1;B1;C1:C50)

Ovenstående formel har en Startdato i A1, et antal dage i B1 og et område i C1:C50 hvor du kan skrive helligdage, ferie, mærkedage evt.
Området hellig/feriedage vil ikke blive medregnet i antallet af dage mellem de to datoer.

Lad os forestille os, at du har brug for at kende leveringsdatoen, hvis du bestiller en vare i dag og leveringstiden er 30 hverdage.
Formlen kunne se såeldes ud: =ARBEJDSDAGE(IDAG();30;C1;C50)
Du vil nu få datoen på leveringdagen.

Omvent, kunne det også være at du ønskede at vide hvornår du skal bestille en vare, for at kunne have den i given dato.
Skriv datoen for hvornår du ønsker at få vare leveret i cellen A1 og igen dine helligdage, ferie og andet i cellerne C1:C50.
Formlen kunne se såeldes ud: =ARBEJDSDAGE(A1;-30;C1;C50)
Du vil nu få den dato du skal bestille varen for at kunne tage den i brug på den ønske dato
 


↑Til toppen

ABS bruges at finde den absolutte værdi af et tal, evt. minus fjernes, så f.eks. -50 bliver til 50

ABS er udmærket hvis du ikke er interesseret i et tal skal stå som minus, et tal behandlet med ABS-formlen vil ALTID stå alene uden fortegn eller andet gøgl.

Formlen ser således ud: =ABS(A1)

I denne formel vil værdien af cellen A1 blive returneret uden fortegn, står der -5 i cellen A1 vil formlen konvertere det til 5
ABS kan kombineres med praktisk talt alle formler, her er lidt eksempler på kombinationer med SUM og SUM.HVIS:
=ABS(SUM(A1:A10)) som summerer værdier i A1:A10 og derefter bruger ABS
=ABS(SUM.HVIS(A1:A10;">10";B1:B10)) som lægger alle tal sammen i b kolonnen hvis A kolonnen er større end 10, og derefter bruger ABS

Man kunne blive ved, prøv selv at eksperimentere!


↑Til toppen

ER.LIGE viser dig om dit tal er lige eller ikke

Rimelig simpelt, men dog alligevel nyttig i hverdagen.

En typisk ER.LIGE formel ser således ud: =ER.LIGE(A1)

Formlen returnerer SAND eller FALSK alt efter om dit tal i A1 er lige eller ulige.

Hvis ER.LIGE kombineres med HVIS, kan du også bestemme hvad formlen skal returneret i stedet for SAND eller FALSK.
Prøv f.eks. =HVIS(ER.LIGE(A1);"Lige";"Ulige") Nu skriver formlen og tallet er lige eller ulige.


↑Til toppen

ER.ULIGE viser dig om dit tal er ulige eller ikke

Stort set samme formel som ER.LIGE, bare omvendt.

En typist ER.ULIGE formel ser således ud: =ER.ULIGE(A1)

Formlen returnerer SAND eller FALSK alt efter om dit tal i A1 er ulige eller lige.

Hvis ER.ULIGE kombineres med HVIS, kan du også bestemme hvad formlen skal returneret i stedet for SAND eller FALSK.
Prøv f.eks. =HVIS(ER.ULIGE(A1);"ULige";"Lige") Nu skriver formlen og tallet er lige eller ulige.


↑Til toppen

FIND giver muligheden for at finde et bogstavs placering i en tekst.

Har du brug for at finde ud af om din tekst indeholder @ eller et andet tegn? eller har du brug for at dele din tekst efter et bestemt bogstav, FIND er formlen for dig.

En typisk FIND formel ser således ud: =FIND(Hansen;A1;1)

Oversat til almindelig Dansk, betyder formlen at: Find teksten 'Hansen' i cellen A1, hvis du finder det skal jeg vide hvor fra venstre ordet 'Hansen' starter.
Hvis cellen A1 indeholder ordet 'Hansen', vil FIND returnere placeringen af første bogstav i ordet.
Hvis der kun står 'Hansen' i A1, vil formlen returnere resultatet 1, da ordet 'Hansen' starter fra bogstav 1
Hvis der står 'Ole Hansen' vil formlen skrive 5

FIND kan kombineres med mange formler, men kombinationen med VENSTRE eller HØJRE er særdeles brugbar, forestil dig følgende:
Vi har en regneark med en liste over medarbejdere i kolonne A, fornavn og efternavn i samme celle.
Vi vil gerne vide fornavnene på medarbejderne er kombinationen VENSTRE et oplagt valg.
Denne formel kan bruges: =VENSTRE(A1;FIND(" ";A1;1))
Nu skriver formlen kun personens fornavn, ved at tælle bogstaver til første mellemrum og derefter skrive det antal bogstaver fra venstre.

At finde efternavnet er noget mere tricky, her kan kombination med HØJRE bruges: =HØJRE(A1;LÆNGDE(A1)-FIND(" ";A1;1))
Efternavnet er fundet, ved at tælle antallet af bogstaver i cellen og derefter trække antal bogstaver før mellemrum fra, nu har man antal bogstaver  som efternavnet er langt.

Lav formlen nogle gange, det er ikke så svært som det ser ud, giv det en chance!


↑Til toppen

FJERN.OVERFLØDIGE.BLANKE renser din tekst for overflødige mellemrum.

Nogle gange får man lidt undelige tekster ud af diverse ERP, økonomi eller Webbaserede værktøjer, så tekster indeholder utroligt mange mellemrum.
De kan fjernes, med den regel at en tekst ikke kan indeholde 2 eller flere mellemrum efter hinanden.

Hvis din tekst står i A1, så lav formlen: =FJERN.OVERFLØDIGE.BLANKE(A1)
Din tekst bliver nu trimmet, så f.eks. teksten: 'Bygaden        13  st.tv' bliver til: 'Bygaden 13 st.tv.'


↑Til toppen

HELTAL returnerer heltalsværdien af tallet som man refererer til.

Ganske enkelt vil HELTAL skære alle decimaler væk, ikke afrunde men faktisk skære decimalerne væk.

HELTAL formlen ser således ud: =HELTAL(A1)

Et eksempel kunne være at A1 indeholder tallet 100,21
Formlen vi returnere tallet 100, uanset om A1 havde indeholdt tallet 100,99 havde formlen stadig returneret tallet 100
Altså er formlen HELTAL Excel's helt egen form for elektronisk rundsav.


↑Til toppen

HVIS bruges mest til at teste om et specielt kriterium er mødt, bruges meget til sammenligning af data.

Den mest almindelige HVIS formel skrives således:   =HVIS(A1=1;"OK";"Ikke OK")

Formlen er en såkaldt logisk formel, som enten kan returnere SAND eller FALSK og tilknytte en handlig til dette.
Større end 1 kan testet ved at bruge formlen således: =HVIS(A1>1;"OK";"Ikke OK")
Forskellig fra 1 kan testes således: =HVIS(A1<>1;"OK";"Ikke OK")

 I stedet for kriteriet "1" kan man i stedet vælge at bruge en celles værdi, f.eks. B1 således: =HVIS(A1=B1;"OK";"Ikke OK")
HVIS er næst efter SUM den mest brugte formel i de fleste små regneark.


↑Til toppen

HØJRE bruges når man skal bruge en del af en tekst eller et tal, ikke det hele, men et antal karakterer eller cifre fra højre side af ordet eller tallet.

Forestil dig at vi har en liste i A-kolonnen som indeholder navne og telefonnumre på medlemmer i foldboldklubben, Palle 99999999, Ole 11111111 osv.
Du vil gerne have telefonnumrene og kun telefonnumrene, her kommer HØJRE ind i billedet.

Formlen ser således ud: =HØJRE(A1;8)

Den kigger i cellen A1 og tager kun de 8 bogstaver eller tal fra Højre, nu har du telefonnummeret på medlemmerne og har sorteret navnene fra.
Hvis der er tale om tal, kan HØJRE bruges til at kalkulere med, =HØJRE(A1;2)+HØJRE(B1;2) lægger de 2 sidste tal i A1 og B1 sammen.

Ønsker du at liste forekomster efter hinanden, kan du bruge & imellem formlerne, =HØJRE(A1;2)&HØJRE(B1;2) vil give de 2 sidste værdier, bogstaver eller tal sat sammen lige efter hinanden, skriver du BO 11 i A1 og PER 22 i B1, så vil denne formel give resultatet 1122


↑Til toppen

IDAG er en meget simpel formel, den returnerer dags dato i den format du ønsker.

Formlen ser således ud: =IDAG()

Formlen returnerer et serienummer, som du ved at formatere cellen, kan ændre til hvad du måtte ønske at format.
Resultatet af formlen kunne være: 39292, som efter en formatering giver datoen: 29-07-2007
IDAG kan også regne dage frem eller tilbage, med udgangspunkt i dags dato.
Samme dag om en uge kunne se således ud: =IDAG()+7
Eller i går: =IDAG()-1


↑Til toppen

LOPSLAG bruges når du ønsker at lave et opslag i én kolonne og få returneret en værdi i samme række, bare i en anden kolonne.

Det kunne være en liste over medarbejdere, hvor du har deres lønnummer i kolonne A og deres navn i kolonne C.
Nu er udfordringen at få Excel til at finde deres navn, ud fra deres lønnummer.

LOPSLAG er vel nok en af de formler som volder begyndere flest kvaler, det er faktisk ikke så svært, giv det en chance.

Den mest almindelige LOPSLAG formel skrives således:   =LOPSLAG("Hej";A1:C30;3;FALSK)

Formlen skal først vide hvad du vil finde, i dette tilfælde er det "Hej"
Dernæst skal den vide hvilket område du vil søge i, her skal du vide hvad en MATRIX er.

En MATRIX er det område som indeholder al data, både det du søger og det du vil finde, LOPSLAG søger altid i den kolonne længst til venstre i det område du vælger som matrix.
Jeg vil søge efter "Hej" i kolonne A og mine data fylder fra A1:C30, så det er min MATRIX

Kolonneindex_nr er egentlig meget simpelt, det er antallet af kolonner mellem den kolonne som søges i og den som jeg vil returnere data fra, den første kolonne fra venstre er A, den har nummer 1, B er 2 og C er 3, jeg vil søge i den 3. kolonne i min matrix.

Lig_med skal som udgangspunkt være FALSK, forskellen på SAND og FALSK er følgende:
Angives SAND, vil formlen returnere den første værdi eller tekst som minder om det man søger efter.
Angives FALSK, vil formlen kun returnere en værdi hvis den finder et nøjagtigt match, hvis ikke match findes returneres #I/T

Formlen kan gøres smartere ved at søge efter en celles værdi eller tekst f.eks.: =LOPSLAG(D1;A1:C30;3;FALSK)
Nu søger den ikke efter "Hej" men efter værdien som står i celle D1
Kolonneindeks_nr kan også være dynamisk, i stedet for den faste kolonne 3 kan man også angive det i en celle, sådan: =LOPSLAG(D1;A1:C30;E1;FALSK)
Nu søger formlen i den kolonne som er angivet i E1, det kunne være 3, men aldrig højere end der er kolonner i matrixen.
Resultaterne af formlerne kan selvfølgelig lægges sammen, men selvfølgelig kun hvis der er tale om tal, dette gøres ved at sætte formlerne efter hinanden med + imellem.


↑Til toppen

LÆNGDE kan måle dine ords længde i antal karakterer.

En typisk LÆNGDE formel ser således ud: =LÆNGDE(A1)

Det virker måske banalt, men denne formel er faktisk ikke så ringe endda.
I den simple udgave, kan den selvfølgelig fortælle dig hvor langt et givent navn eller tal er, hvilket ikke er så tosset, da man kan bruge den til at validere f.eks Danske postnumre, de skal være 4 cifre.
Hvis postnummeret i A1 f.eks er 4700, så vil LÆNGDE returnere tallet 4, for 4700 består af 4 tegn.

Nu brugte vi postnumre i ovenstående eksempel, dem kan vi bruge igen.
Til lidt mere avanceret brug kunne man jo forestille sig at enkelte ville taste 3 cifrede postnumre, da enkelte starter med 0, den klarer vi også med LÆNGDE.
Kombinerer du LÆNGDE med HVIS, så kan man klare den.
=HVIS(LÆNGDE(A1)<4;0&A1;A1)
Forklaret på Dansk, hvis længden på A1 er mindre end 4, så skal der et 0 foran a1, ellers ikke.

Nu giver brugen af LÆNGDE pludselig mening.


↑Til toppen

MIDT er en fantastisk formel som giver mulighed for at tage en del af en tekst og arbejde videre med den.

En typisk MIDT formel ser således ud: =MIDT(A1;3;4)

Ovenstående formel kigger i cellen A1, starter ved tegn nr. 3 fra venstre og returnerer 4 tegn mod højre.
Hvis vi nu siger at cellen A1 indeholder et telefonnummer, f.eks 54996099, vil formlen returnere 9960.

Formlen kombinerer højre og venstre kan man sige, du er nemlig ikke låst til at tage udgangspunkt i et bestemt sted i din tekst, det giver nogle rigtig gode muligheder.

Som så mange andre formler, kan du bruge tegnet "&" imellem formlerne og derved kombinere flere af gangen.
Nu får du mulighed for at manipulere med din tekst, forestil dig en formel som igen tager udgangspunkt i ovenstående telefonnummer.
Laver man formlen: =MIDT(A1;3;6)&MIDT(A1;1;2) så flytter man de 2 første cifre i nummeret til at være de sidste i nummeret, altså 54996099 bliver til 99609954

Dette var blot et eksempel, du kan sikker finde på mange flere.


↑Til toppen

RUND.NED bruges når man ønsker at runde et tal ned til nærmeste multiplum som det så fint hedder, sagt på menneskesprog er det bare at runde ned til et antal decimaler du vælger.

En typisk RUND.NED formel ser således ud: =RUND.NED(A1;2)

Formlen vil således tage indholdet af A1 og ændre det til 2 decimaler, vel at mærke ved at runde ned til nærmeste 2 decimaler.
Til forskel for at formatere en celle, vil denne formel ændre tallet rent fysisk.
Det er en rigtig god formel at bruge når man afslutningsvis laver en sum forneden, så undgår du at andre slår tallene ind på deres lommeregner og kommer frem til at andet resultat pga. afrundingen af decimaler som er skjult af en formatering.


↑Til toppen

RUND.OP bruges når man ønsker at runde et tal op til nærmeste multiplum som det hedder på fagsprog, for almindelig dødelige er det bare at runde op til et antal decimaler du vælger.

En typisk RUND.OP formel ser således ud: =RUND.OP(A1;2)

Formlen vil således tage indholdet af A1 og ændre det til 2 decimaler, vel at mærke ved at runde op til nærmeste 2 decimaler.
Til forskel for at formatere en celle, vil denne formel ændre tallet rent fysisk.
Det er en rigtig god formel at bruge når man afslutningsvis laver en sum forneden, så undgår du at andre slår tallene ind på deres lommeregner og kommer frem til at andet resultat pga. afrundingen af decimaler som er skjult af en formatering.


↑Til toppen

SAMMENKÆDNING sammenkæder tekst eller tal fra flere celler til en

Formlen er meget simpel og ser som oftest således ud: =SAMMENKÆDNING(A1;B1;C3)
Hvis vi holder fast i ovenstående formel og noterer at der i A1 står et fornavn (Bo), i B1 står der et mellemnavn (Børge) og i C1 et efternavn (Bundesen).
Formlen vi returnere BoBørgeBundesen.
Det ville nok se en smule pænere ud hvis der var mellemrum mellem navnene, så formlen skal modificeres lidt til: =SAMMENKÆDNING(A1;" ";B1;" ";C3)
Resultatet bliver nu Bo Børge Bundesen.
Du kan faktisk skrive hvad du vil i SAMMENKÆDNING formlen, du skal blot huske at resultatet altid bliver en tekst, det kan ikke formateres.

Er du mere interesseret i at benytte SAMMENKÆDNING med tal som du kan regne videre på, kan resultatet ganges med 1.
Nu kan du regne videre på et tal som er samlet af flere små bidder, =SAMMENKÆDNING(A1;B1;C1)*1
Ved at gange med 1, tvinges Excel til at se din sammenkædning som et tal.


↑Til toppen

SUM bruges til at lægge tal sammen, et godt alternativ til +

Formlen er vel nok den mest kendte i Excel, dens opbygning er således: =SUM(A1:A10)
Formlen lægger alle tal sammen i cellerne A1:A10
Formlen kan udbygges til at inkludere flere tal som ikke umiddelbart hænger sammen, sådan: =SUM(A1;A3;A5;A7)
Normalt vil man lave denne formel sådan =A1+A3+A5+A7  resultatet er det samme.
Områder angives med kolon (A1:A10 = A1 til A10) mens enkelte celler angives med semikolon (A1;A10 = A1 og A10)

For at øge overskueligheden i +/- stykker, kan SUM bruges så man først lægger tal sammen og derefter trækker dem fra hinanden. Det kunne se således ud: =SUM(A1:A10)-SUM(A1:A10)
Hvis dette formel skulle laves med + og - ville den se således ud: =A1+A2+A3+A4+A5+A6+A7+A8+A9+A10-B1-B2-B3-B4-B5-B6-B7-B8-B9-B10. Totalt uoverskuelig


↑Til toppen

SUM.HVIS bruges når du ønsker at lave en SUM efter visse kriterier, kriteriet kan være en speciel type, værdi eller tekst.

Regn f.eks. ud hvor stor en andel af det totale salg i forretningen har Per stået for.

Den mest almindelige SUM.HVIS formel skrives således:   =SUM.HVIS(A1:A10;"Per";B1:B10)

Formlen søger i området A1:A10 og finder alle forekomster af "Per", tal i samme række i B kolonnen summeres.
Den bruges til at summere, men er totalt afhængig af der findes et 100% match, F. eks "PER" og "per hansen" vil ikke blive talt med.

Sum.Hvis kan også summere antal større eller mindre end, det gøres således: =SUM.HVIS(A1:A10;">10";B1:B10) eller =SUM.HVIS(A1:A10;">"&10;B1:B10) som er mere korrekt

Nu summeres antallet af forekomster større end 10, dette kan selvfølgelig ændres til mindre end hvis det ønskes.
Funktionen større end eller lig med kræver at man bruger "gåseøjne" og "&" i formlen, således: =SUM.HVIS(A1:A10;">="&10;B1:B10)
Så alle tal som er = 10 eller større tælles.

Resultaterne af formlerne kan selvfølgelig lægges sammen, dette gøres ved at sætte formlerne efter hinanden med + imellem.


↑Til toppen

TÆL bruges til at tælle antallet af numeriske værdier i et område.

Almindeligvis bruges TÆL således: =TÆL(A1:A10)

Her tælles antallet af tal i området A1:A10, tekst ignoreres totalt.
Tal som 1, 2,5 og 100 tælles, mens kombinationer som A1, Agent 007 osv. ikke tælles.
Formlen kan tælle flere områder/celler af gangen, dvs. en formel som =TÆL(A1;A2;A3;A4:A10) kan lade sig gøre, selvom den næppe giver mening.
Områder angives med kolon (A1:A10 = A1 til A10) mens enkelte celler angives med semikolon (A1;A10 = A1 og A10)


↑Til toppen

TÆL.HVIS bruges hvis du ønsker at tælle forekomster af en speciel type, værdi eller tekst.

F. eks hvor mange af foldboldspillerne på listen har betalt kontingent, Ja eller Nej!

Den mest almindelige Tæl.Hvis formel skrives således:   =TÆL.HVIS(A1:A10;"Ja")

Formlen søger i området A1:A10 og tæller antal forekomster af "Ja"
Den bruges til at tælle forekomster, men er totalt afhængig af der findes et 100% match, F. eks JA og ja vil ikke blive talt med.
Tæl.Hvis kan også tælle antal større eller mindre end, det gøres således: =TÆL.HVIS(A1:A10;">10") eller =TÆL.HVIS(A1:A10;">"&10) som er mere korrekt
Nu tælles antallet af forekomster større end 10, dette kan selvfølgelig ændres til mindre end hvis det ønskes.

Funktionen større end eller lig med kræver at man bruger "gåseøjne" og "&" i formlen, således: =TÆL.HVIS(A1:A10;">="&10) så alle tal som er = 10 eller større tælles.
Resultaterne af formlerne kan selvfølgelig lægges sammen, dette gøres ved at sætte formlerne efter hinanden med + imellem.


↑Til toppen

UGEDAG bruges typisk når man vil vide hvilken ugedag (mandag, tirsdag osv.) en bestemt dato repræsenterer.

Forestil dig at du har lavet en kalender i Excel, datoerne har du tastet ind, men nu vil du have ugedagene henover.

En typisk UGEDAG formel ser således ud: =UGEDAG(A1;1)

Hvis cellen A1 indeholder en dato, vil formlen returnere et tal, dette tal hvilken ugedag der er tale om.
Som du sikkert har lagt mærke til, er formlen opdelt i SERIENR og TYPE, forklaringen kommer her:
SERIENR er bare den dato du vil hente ugedagen fra, altså A1 i eksemplet foroven.
TYPE er en brugerdefineret måde at bestemme hvilken af ugens dage der er den første på ugen.
Hvis Type = 1 så er Søndag = 1 og Lørdag = 7
Hvis Type = 2 så er Mandag = 1 og Søndag = 7
Hvis Type = 3 så er Mandag = 0 og Søndag = 6
Hvis du ikke angiver nogen Type, så vil Excel bruge 1 (Søndag = 1 og Lørdag = 7)

UGEDAG kan også give dig den aktuelle ugedag, sådan: =UGEDAG(IDAG())
Eller f.eks. dagen i går: =UGEDAG(IDAG()-1)

Tallet som denne formel returnerer, kan du formatere som du vil, men hvis du formaterer som Brugerdefineret: dddd, vil den skrive navnet på dagen og ikke bare et tal. 1 bliver til søndag, 2 bliver til mandag osv.


↑Til toppen

VENSTRE bruges når man skal bruge en del af en tekst eller et tal, ikke det hele, men et antal karakterer eller cifre fra venstre side af ordet eller tallet.

Forestil dig at vi har en liste i A-kolonnen som indeholder nummer og navne på soldaterne i en deling, 22 Jørgensen, 23 Petersen osv.
Du vil gerne have numrene og kun numrene, her kommer VENSTRE ind i billedet.

Formlen ser således ud: =VENSTRE(A1;2)

Den kigger i cellen A1 og tager kun de 2 første bogstaver eller tal fra Venstre, nu har du nummeret på soldaten og ikke navnet.
Hvis der er tale om tal, kan VENSTRE bruges til at kalkulere med, =VENSTRE(A1;2)+VENSTRE(B1;2) lægger de 2 første tal i A1 og B1 sammen.

Ønsker du at liste forekomster efter hinanden, kan du bruge & imellem formlerne, =VENSTRE(A1;2)&VENSTRE(B1;2) vil give de 2 første værdier, bogstaver eller tal sat sammen lige efter hinanden, skriver du 11 i A1 og 22 i B1, så vil denne formel give resultatet 112.


↑Til toppen

VOPSLAG bruges når du ønsker at lave et opslag i én række og få en værdi i samme kolonne men bare i en anden række.

Det kunne være en vagtplan, hvor du har datoer i række 1 og skal finde en vagt længere nede i rækkerne men altid i samme kolonne.
Den er nok en af de formler som volder begyndere flest kvaler, det er faktisk ikke så svært, giv det en chance.

Den mest almindelige VOPSLAG formel skrivessåledes:   =VOPSLAG("Hej";A1:N10;3;FALSK)

Formlen skal først vide hvad du vil finde, i dette tilfælde er det "Hej"
Dernæst skal den vide hvilket område du vil søge i, her skal du vide hvad en MATRIX er.

En MATRIX er det område som indeholder al data, både det du søger og det du vil finde, VOPSLAG søger altid i den øverste række i det område du vælger som matrix.
Jeg vil søge efter "Hej" i række 1 og mine data fylder fra A1:N10, så det er min MATRIX

Rækkeindex_nr er egentlig meget simpelt, det er antallet af række mellem øverste række som søges i og den som jeg vil returnere data fra, den første række jeg har angivet er række 1, den har nummer 1, 2 er 2 og 3 er 3, jeg vil søge i den 3. række i min matrix.

Lig_med skal som udgangspunkt være FALSK, forskellen på SAND og FALSK er følgende:
Angives SAND, vil formlen returnere den første værdi eller tekst som minder om det man søger efter.
Angives FALSK, vil formlen kun returnere en værdi hvis den finder et nøjagtigt match, hvis ikke match findes returneres #I/T

Formlen kan gøres smartere ved at søge efter en celles værdi eller tekst f.eks.: =VOPSLAG(A12;A1:N10;3;FALSK)
Nu søger den ikke efter "Hej" men efter værdien som står i celle A12
Rækkeindex_nr kan også være dynamisk, i stedet for den faste række 3 kan man også angive det i en celle, sådan: =VOPSLAG(A12;A1:N10;B12;FALSK)
Nu søger formlen i det rækkenummer som er angivet i B12, det kunne være 3, men aldrig højere end der er rækker i matrixen.
Resultaterne af formlerne kan selvfølgelig lægges sammen, men selvfølgelig kun hvis der er tale om tal, dette gøres ved at sætte formlerne efter hinanden med + imellem.

 

Opdateret 10-02-2017 14:57:05